2 Replies Latest reply on Jun 20, 2016 10:47 AM by Terri Harris

    Event Log plagued with same error

    Kris Foster

      Hi All,

       

      I know I've seen this one before, but I can't seem to recall what is the cause of it.  The event log is plagued with the following error for all feature classes in ArcMap when a user starts editing.  It doesn't seem to have any ill effect aside from filling up the event log with a lot of errors.

       

      2016-06-02 17:38:55,521 [1] ERROR  [(null)] - "Unable to put subtype code: -1 for feature class: <FeatureClassName>"

       

      HRESULT: -2147467259

      File: "d:\root\source\com\components\mmgeoobjects\IFeatureEditImpl.h"

      Line: 295

      {log4net:HostName=HEDevClient1, log4net:UserName=UDCUS\kfoster, LoggingAssemblyFileVersion=10.21.20.1854, log4net:Identity=}

       

      Thanks!

      Kris Foster

        • Re: Event Log plagued with same error
          Terri Harris

          Hello Kris,

           

          This is Terri with ArcFM Support and I'll try to help if I can. This "unable to put subtype code" error has been seen in the past but not commonly & we haven't always been able to track it down. Hopefully we can narrow this one down.

           

          1. Any idea when it first started? I'm hoping you have at least one Miner event log that goes back awhile so we can verify when it first started.

           

          2. Is the error consistent with any and all users when they got into edit mode? If you use either Designer or Session Manager can you try using just ESRI tools to go into edit mode? If so does the error still appear?

           

          If you can please attach the Miner event log here, saved as a native evtx file. Files up to almost 2 GB can be attached by selecting Use advanced editor in upper right. The advanced editor has a attach option in the lower right of its screen.

           

          Sincerely,

           

          - Terri Harris, ArcFM Support

          • Re: Event Log plagued with same error
            Terri Harris

            Kris,

             

            Can you try starting with a blank map & adding just the layers you need? This may be a Stored Display layer issue where a layer is referencing a subtype that no longer exists. Do you symbolize based on subtypes?

             

            - Terri