2 Replies Latest reply on Jun 3, 2016 10:45 AM by Dori Bearham

    Designer license unavailable in stand-alone app

    Dori Bearham

      I'm working on a stand-alone app and successfully get an ESRI license but I can't get a Designer license. I'm using the same code that is in the developer documentation to get the Designer license but the 2nd line of code is false because mmLS = mmLicenseUnavailable

       

                  mmLicenseStatus mmLS = _mmAppInit.IsProductCodeAvailable(mmLicensedProductCode.mmLPDesigner);

                  if (mmLS == mmLicenseStatus.mmLicenseAvailable)

                  {

                      mmLS = _mmAppInit.Initialize(mmLicensedProductCode.mmLPDesigner);

                      if (mmLS != mmLicenseStatus.mmLicenseCheckedOut)

                      {

                          ExeMessages(null, null, "ExecutePxTask.PutIntoMapping - could not check out Designer license. License status is " + mmLS, DateTime.Now);

                          return;

                      }

                  }

                  else

                  {

                      ExeMessages(null, null, "ExecutePxTask.PutIntoMapping - Designer license is not available. License status is " + mmLS, DateTime.Now);

                      return;

                  }

       

      I have verified that the ArcFM Desktop Administrator is pointing to the correct license manager and there are plenty of Designer licenses available.

       

      There is an error write to the Miner event log:

      The description for Event ID 0 from source Miner and Miner cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

       

      If the event originated on another computer, the display information had to be saved with the event.

       

      The following information was included with the event:

       

      Licensing Failure:  + [CoCreateInstance CLSID_LicenseClient failed]  -2147221164

       

      Any help would be much appreciated. Has anyone run across this behavior before? Could it be a permissions thing?