1 Reply Latest reply on Jan 20, 2016 9:29 AM by Ed Blair

    PxAdmin "An error relating to security occurred"

    Ed Blair

      All -

       

      Here's a weird one that I've never seen before.  Have been using the PxAdmin tool to configure a database for ArcFM and Designer.   Has worked fine for months, until yesterday when I started receiving the error message below.  The error appears immediately after login.

       

      A particularly odd thing about this one is that I get the error regardless of the database I'm trying to connect to.  I get it when I try to connect to either Oracle database I'm working with.   And it also occurs when I try to connect to the SessionManager.mdb that's delivered with the ArcFM sample data.

       

      One suggestion I received was to re-install all ArcFM software as an administrator.  Did this.  Same problem persists.

       

      Also, other users connected to the same Oracle database running the PxAdmin tool on different machines can connect to it successfully.   So it seems to be an issue with the particular machine I'm running on.

       

      Other parts of ArcFM seem to be operating as expected.

       

      If anyone has seen this any info about it would be much appreciated.    I'll post any findings.

       

      Thanks,

      Ed

       

        • Re: PxAdmin "An error relating to security occurred"
          Ed Blair

          So, here's what seemed to have happened to cause this error.

           

          We have a custom control for WFM Work Requests.  The DLL gets registered in the COM Category "M&M Process Framework Control" and configured in the PxAdmin tool States tab.  This was built and tested in a development environment and worked fine.

           

          To expose the control to a broader audience the DLL was moved to a shared drive location (Z: ), the old location unregistered and the new location registered in the COM Category. 

           

          Once that was done the PxAdmin tool seems to have lost track of when the component was registered and threw up the error shown above.  Once the DLL was unregistered from the shared drive location and to a positively known location all was good.

           

          At this point the problem *may* be that a drive mapping (Z: ) was used instead of a UNC path (i.e,, \\servername\sharename\path\file).  Still working on this.

           

          Ed