0 Replies Latest reply on Jun 15, 2015 4:21 PM by Jennifer Hall

    2 weeks ago my Editor on ArcGIS stopped working. I cannot edit anything; add, delete, or make corrections to existing features and layers. Can you help me?

    Jennifer Hall

      For the past 2 to 3 weeks I have been a way from my desk out in the field, so I don't know how this started or when.

      The last time I was on ArcFM and knew it was working was Friday 05/29 I was also trying to set up an Address Locator file that worked but ended up creating and deleting a lot.

      The day I found out that AcrGIS or ArcFM stopped letting me edit was Tuesday 06/02 at the end of the day. I tried to add a handhole and delete a fiber cable but I was just getting a window that popped up saying


      "Modify Feature: An unexpected failure occured.

      General Feature Failure

      Cannot open database 'CREATE TABLE [DELTA_SplicePoint] ( [DELTA_ID]

      AUTOINCREMENT NOT NULL , [DELTA_ISNEW] SHORT NO NULL ,

      [DELTA_ISDELETED] SHORT NO NULL , [Shape] LONGBINARY , [OBJECTID]

      LONG NOT NULL , [AncillaryRole] SHORT , [ENABLED] SHORT , [CreationUser]

      TEXT(50) , [DateCreated] DATE , [LastUser] TEXT(50) , [DateModified] DATE ,

      [SpliceEnclosureType] TEXT (50) , [Owner] TEXT(255)

      [SpliceEnclosureManufacturer] TEXT(255) , [SpliceEnclosureModelNumber]

      TEXT(255) , [InstalledBy]


      So I cant do any editing whats so ever and have no idea why. I thought it might just be a ArcGIS problem so I called ESRI's IT support and hoped they could tell me what was wrong. They couldn't figure anything out except that if I created a new Geodatabase and copy and paste all the files from the first into the new one I could then edit the features but I cant use any of the ArcFM buttons. And if I try and use connection manager or any of the ArcFM buttons a window pops up saying


      "No connectable objects found. Report Cannot be generated"

       

      So what I need help with is either getting the first geodatabase to work and let me edit features and connections OR get the new geodatabase to have all the buttons on ArcFM work and somehow add all the data that is missing for Fiber manager.