7 Replies Latest reply on Nov 6, 2014 6:30 PM by Tim Szekely

    Could not open workspace.

    Samuel Valdez

      I want to mention Fiber Manager, Jon Ronat, and Melia Brush as well.

       

      Last Wed, I posted a somewhat complicated set of edits, mostly deleted, updated, and inserted fiber optic cables.  The QA/QC process did not reveal any errors.  Soon afterward, in ArcFM 10.2 (not ArcFM Viewer), outside of an edit session, I tried to open the Connection Manager on a splice point, and I got the attached dialog, which contains the message that is in the discussion topic.  We have never seen this dialog before, and I assumed that it was somehow caused by my preceding posting activity, and that the (Oracle 11.2.0.3.0) database was now corrupted.  To resolve this perceived issue, I asked that the database be restored from Tue night's backup.

       

      After the database was restored, I tried the same sequence of activities (ArcFM Viewer, no session, Connection Manager) and I got the same dialog.  This leads me to believe that this problem has nothing to do with my post, and that it has existed for some time without our knowledge.  I found some possibly-related information here: http://help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//00vq0000000m010167

       

      Curiously, I can successfully perform the same series of events (without the post) if I use a different stored display, or if I try it in a session.  I also saved the offending stored display in an MXD file and ran the MXDDoctor on the file, to no avail.  This behavior is exhibited using database accounts that have editing privileges, and administrative privileges.  It appears that otherwise, we can perform all of our normal digitizing/editing activities as before.  At this point, I am suspecting some kind of subtle permissions problem, but I and not sure how to proceed with an investigation, or how to resolve the issue, so I have started this discussion to see if anyone can provide us with some guidance.  Thank you in advance for any help that you may be able to offer!

        • Re: Could not open workspace.

          Hi Sam - It does sound like it may be a privileges issue. Have you tried connecting as the database owner? If that works, it is a privilege issue - probably with a table used to maintain connections.

           

          I am adding mentions of Brian Higgins and Ebony Fellman - they can supply details.

          • Re: Could not open workspace.
            Ebony Fellman

            Hello Samuel!

            You mentioned that the problem doesn't happen if you use a different stored display.  Does your stored display include any layers from other sources (other geodatabases or shapefiles)?

             


            Thanks!
            Ebony Fellman

            Schneider Electric Technical Support

              • Re: Could not open workspace.
                Samuel Valdez

                Yes.  Besides the Oracle-based enterprise geodatabase, there are three file geodatabases that are "local" (via mapped network drive) to my PC, where ArcFM is installed:

                 

                WorkspaceManagerDialog.jpg

                 

                The stored display that works only contains the SDE.DEFAULT line above.  In ArcCatalog, I can see all three file geodatabases and inspect their contents.  In the file system, two of the three file geodatabases appear to have a related file:

                • FiberOpticCable.gdb.fm (last modified 09 Jun 2104)
                • 20131120_FiberCableNaming.gdb.fm (last modified 08 Jan 2014)

                Is there any other information that I can provide that might help us resolve this?

                  • Re: Could not open workspace.
                    Ebony Fellman

                    Hi Samuel,

                    It sounds like SDE is your main fiber database?
                    In the ArcMap table of contents, what layer is listed at the top?
                    Is it a layer from another workspace?  If so, can you remove that layer or position it so that it is beneath an SDE.Default layer?


                    Thanks,
                    Ebony

                      • Re: Could not open workspace.
                        Samuel Valdez

                        Yes, SDE is our main fiber database.

                         

                        In the ArcMap table of contents, feature classes from two of the file geodatabases are listed above the SDE feature classes.  The basemap file geodatabase is at the bottom, below the SDE feature classes.  I just (temporarily) moved the feature classes (all in a single Group Layer) that were above the SDE feature classes to below the SDE feature classes (as you requested) but above the basemap feature classes, and now the Connection Manager successfully opens on the same splice point, outside of a session, so that is encouraging.

                         

                        Please note the following:

                        1. The previous ArcMap table of contents arrangement has always worked just fine.
                        2. We have not recently (within a few months) changed any of the feature classes inside of the file geodatabase, nor the file geodatabase paths.
                        3. We have not upgraded ArcFM with any patches, etc., ever.

                         

                        Does this help you narrow down what is wrong, and how to fix it?  (Ideally, we would like to retain the original ArcMap table of contents layer-order.)  Also, how could this have become broken in the first place?