3 Replies Latest reply on Mar 11, 2014 3:07 PM by Brittany Wall

    We are trying to test our 10.0.3 database with ST-Geometry and we are getting all kinds of errors.

      A case was opened with ESRI support and they are asking about ArcFM Objects existing in our database. Of course most of our datasets are ArcFMified and all are versioned. We have tried to drop spatial indexes (successfully) and tried to add new spatial indexes (failed). We are seeing  numerous ORA-xxx errors depending on what we've tried to do. I have more information and screenshots available. We're just not sure which direction to start! We've had errors from editing to compressing the database. In fact now we can't edit our water and wastewater datasets that we tried to recalculate the spatial indexes on.

      This error is common for what we are seeing (this one is from our UGStructure layer) :

       

      Database Row Change: An unexpected failure occured.

      Underlying DBMS error [ORA-29875: failed in the execution of the ODCIINEXINSERT routine

      ORA-20085: Insert Spatial Reference SRID 4 does not match

      ARCFM.A358.SHAPE registered Spatial Reference SRID 0

      ORA-06512: at "SDE.ST_DOMAIN_METHODS", line 1958

      ] [ARCFM.UGStructure]