Solution - Designer - 'Send to Design' does not work on CU Favorites.

Version 6

    Behavior

     

    The 'Send to Design' option does not work as expected on CU favorites.

    Error messages similar to the following may be reported in Miner Event Viewer:

    2013-08-20 17:02:49,365 [1] ERROR  [(null)] - Miner & Miner ListItem TreeView Control:
    Send to Desi&gn CLSID= : MMTreeToolInfo.Execute:
    MMSendToDesign.cls.IMMTreeViewTool_Execute:
    MMSendToDesign.cls.ValidCuWorkFunction:
    MMSendToDesign.cls.ValidCuWorkFunction:
    MMSendToDesign.cls.ValidCuWorkFunction:
    Type mismatch
    Error at line: 239 - Build: 10.3.7494
    Error at line: 245 - Build: 10.3.7494
    Error at line: 245 - Build: 10.3.7494
    Error at line: 153 - Build: 10.3.7494
    Error at line: 158 - Build: 10.3.7494
    {log4net:HostName=w7-64, LoggingAssemblyFileVersion=10.03.0.7494}

     

    2013-08-20 17:02:49,365 [1] ERROR  [(null)] - MMRelTools.dll:
    MMSendToDesign.cls.IMMTreeViewTool_Execute:
    MMSendToDesign.cls.ValidCuWorkFunction:
    MMSendToDesign.cls.ValidCuWorkFunction:
    MMSendToDesign.cls.ValidCuWorkFunction:
    Type mismatch
    Error at line: 239 - Build: 10.3.7494
    Error at line: 245 - Build: 10.3.7494
    Error at line: 245 - Build: 10.3.7494
    Error at line: 153 - Build: 10.3.7494
    {log4net:HostName=w7-64, LoggingAssemblyFileVersion=10.03.0.7494}

     

    Cause

     

    This problem may be related to the following bug resolved in ArcFM 10.0.3SP1 and 10.1:
    MM46313  CU Tab -- Unable to use 'Send to Design' on CU favorites.

     

    Workaround

     

    A patch is available for ArcFM 10.0.3.